summaryrefslogtreecommitdiff
path: root/hello/CMakeLists.txt
diff options
context:
space:
mode:
author3gg <3gg@shellblade.net>2024-11-27 13:41:09 -0800
committer3gg <3gg@shellblade.net>2024-11-27 13:41:09 -0800
commitc8be8496c8a15d0ede8338939a7512109b8e5e46 (patch)
tree1e60112652e9f3c3a20e6bf4cc0b8bef0ebc81fd /hello/CMakeLists.txt
Initial commit.
Diffstat (limited to 'hello/CMakeLists.txt')
-rw-r--r--hello/CMakeLists.txt11
1 files changed, 11 insertions, 0 deletions
diff --git a/hello/CMakeLists.txt b/hello/CMakeLists.txt
new file mode 100644
index 0000000..e4b4acc
--- /dev/null
+++ b/hello/CMakeLists.txt
@@ -0,0 +1,11 @@
1cmake_minimum_required(VERSION 3.28)
2
3project(cuda_hello LANGUAGES CUDA CXX)
4
5add_executable(cuda_hello
6 hello.cu)
7
8# -Wpedantic causes warnings due to nvcc emitting non-standard (gcc-specific)
9# host code.
10# https://stackoverflow.com/questions/31000996/warning-when-compiling-cu-with-wpedantic-style-of-line-directive-is-a-gcc-ex
11target_compile_options(cuda_hello PRIVATE -Wall -Wextra -Wno-pedantic)