aboutsummaryrefslogtreecommitdiff
path: root/timer/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'timer/CMakeLists.txt')
-rw-r--r--timer/CMakeLists.txt23
1 files changed, 23 insertions, 0 deletions
diff --git a/timer/CMakeLists.txt b/timer/CMakeLists.txt
new file mode 100644
index 0000000..d915163
--- /dev/null
+++ b/timer/CMakeLists.txt
@@ -0,0 +1,23 @@
1cmake_minimum_required(VERSION 3.10)
2
3project(timer)
4
5# Library
6
7set(SRC
8 src/timer.c)
9
10add_library(timer ${SRC})
11
12target_include_directories(timer PUBLIC include)
13
14target_compile_options(timer PRIVATE -Wall -Wextra)
15
16# Test
17
18add_executable(timer_test
19 test/timer_test.c)
20
21target_link_libraries(timer_test timer)
22
23target_compile_options(timer_test PRIVATE -DUNIT_TEST -DNDEBUG -Wall -Wextra)