aboutsummaryrefslogtreecommitdiff
path: root/error/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'error/CMakeLists.txt')
-rw-r--r--error/CMakeLists.txt14
1 files changed, 14 insertions, 0 deletions
diff --git a/error/CMakeLists.txt b/error/CMakeLists.txt
new file mode 100644
index 0000000..e47a1f9
--- /dev/null
+++ b/error/CMakeLists.txt
@@ -0,0 +1,14 @@
1cmake_minimum_required(VERSION 3.0)
2
3project(error)
4
5add_library(error
6 src/error.c)
7
8target_include_directories(error PUBLIC
9 include)
10
11target_link_libraries(error
12 cstring)
13
14target_compile_options(error PRIVATE -Wall -Wextra)