aboutsummaryrefslogtreecommitdiff
path: root/mempool/CMakeLists.txt
diff options
context:
space:
mode:
author3gg <3gg@shellblade.net>2021-12-04 16:01:12 -0800
committer3gg <3gg@shellblade.net>2021-12-04 16:01:12 -0800
commitf8217d240d598f39f70047f7a623dd46312542c6 (patch)
tree4e40843d665e388416c1226f739c2b8c0b8da736 /mempool/CMakeLists.txt
parent5f6ea503cdb6ad4a95b679672a1ad324d96c89a5 (diff)
Initial commit.
Diffstat (limited to 'mempool/CMakeLists.txt')
-rw-r--r--mempool/CMakeLists.txt23
1 files changed, 23 insertions, 0 deletions
diff --git a/mempool/CMakeLists.txt b/mempool/CMakeLists.txt
new file mode 100644
index 0000000..1ff4ff1
--- /dev/null
+++ b/mempool/CMakeLists.txt
@@ -0,0 +1,23 @@
1cmake_minimum_required(VERSION 3.16)
2
3project(mempool)
4
5# Library
6
7add_library(mempool
8 src/mempool.c)
9
10target_include_directories(mempool PUBLIC
11 include)
12
13target_compile_options(mempool PRIVATE -Wall -Wextra)
14
15# Test
16
17add_executable(mempool_test
18 test/mempool_test.c)
19
20target_link_libraries(mempool_test
21 mempool)
22
23target_compile_options(mempool_test PRIVATE -DUNIT_TEST -DNDEBUG -Wall -Wextra)