aboutsummaryrefslogtreecommitdiff
path: root/random/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'random/CMakeLists.txt')
-rw-r--r--random/CMakeLists.txt10
1 files changed, 10 insertions, 0 deletions
diff --git a/random/CMakeLists.txt b/random/CMakeLists.txt
new file mode 100644
index 0000000..ec80b1d
--- /dev/null
+++ b/random/CMakeLists.txt
@@ -0,0 +1,10 @@
1cmake_minimum_required(VERSION 3.0)
2
3project(random)
4
5add_library(random
6 src/mt19937-64.c)
7
8target_include_directories(random PUBLIC include)
9
10target_compile_options(random PRIVATE -Wall -Wextra)